Block DNS Over HTTPS Mikrotik

Sedikit gambaran DNS Over HTTPS (DoH), ini sama seperti request DNS pada umumnya hanya saja yang membedakan adalah saat request dilakukan encryption data, sehingga DNS lebih privacy.

Lantas kenapa dilakukan Block DNS Over HTTPS ?? mungkin ini pertanyaan yang ada dibenak sanak saudara. Melakukan blok DoH sendiri merupakan kebijakan masing-masing saja.

Sebagai gambaran bila user atau client dapat menggunakan fasilitas DNS Over HTTPS (DoH) maka user atau client bisa atau dapat mengakses situs/website ilegal yang diblokir pemerintah seperti playboy.com pornhub dll.

Jadi silahkan Anda tentukan pilahan tersebut, akan diblock atau open

Membuat Address List

Pada mikrotik buatlah address list dari penyedia layanan DoH

/ip firewall address-list
add list="DoH" address="1.1.1.1"
add list="DoH" address="1.0.0.1"
add list="DoH" address="8.8.8.8"
add list="DoH" address="8.8.4.4"
add list="DoH" address="162.158.43.82"
add list="DoH" address="9.9.9.9"
add list="DoH" address="104.18.16.0/20"
add list="DoH" address="185.228.168.0/24"
add list="DoH" address="208.67.222.222"
add list="DoH" address="208.67.220.220"
add list="DoH" address="104.16.240.0/20"
add list="DoH" address="firefox.dns.nextdns.io"
add list="DoH" address="doh.opendns.com"

Membuat Filter

Setelah address list, langkah selanjutnya adalah membuat filter dengan melakukan block port 443 dengan tujuan DNS penyedia layanan

/ip firewall filter add chain=forward dst-address-list="DoH" protocol=tcp dst-port=443 action=drop

Sampai disini tugas sudah selesai, bila ada pertanyaan silahkan ditanyakan dikolom komentar.

Baca juga :  Melakukan Block Streaming di Mikrotik

Leave a Comment