Cara Backup Mikrotik ke FTP Server

Cara Backup Mikrotik ke FTP Server. Pengguna mikrotik tak lepas dari kata backup, yang merupakan hal terpenting bila sewaktu-waktu perangkat mengalami masalah. Banyak metode untuk melakukan backup konfigurasi Mikrotik, bisa dilakukan secara manual Melalui WInbox (Files Backup). Atau bisa juga melalui scripting yang nantinya file backup dikirim melalui email.

Cara Backup Mikrotik ke FTP Server

Disini penulis mencoba membagi script untuk Backup Mikrotik ke FTP Server, saya tidak akan membahan bagaimana membuat FTP Server. Mungkin lain waktu akan saya bahas membuat FTP Server sebagai backup Mikrotik

Berikut Script Cara Backup Mikrotik ke FTP Server

Silahkan rubah scriptnya dan sesuaikan dengan kebutuhan yang diperlukan.

##################################
# Backup Mikrotik ke FTP Server
# @paidjo.com 072017
##################################

# TULIS DENGAN HURUF BESAR dan "-" untuk lebih dari satu kata
:local nama "ROUTER-PAIDJO-COM"

## DO NOT EDIT FROM HERE TO THE END!
# ftp configuration
:local ftphost "192.168.2.248"
:local ftpport "2121"
:local ftpuser "user"
:local ftppassword "password"
:local ftppath "backup"

# months array
:local months ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
#get Time
:local tm [/system clock get time]
:local jam [:pick $tm 0 2 ]
:local menit [:pick $tm 3 5 ]
:local detik [:pick $tm 6 8 ]
:set $waktu ($jam.".".$menit.".".$detik)
# get Date
:local ds [/system clock get date]
# convert name of month to number
:local month [ :pick $ds 0 3 ];
:local mm ([ :find $months $month -1 ] + 1);
:if ($mm < 10) do={ :set mm ("0" . $mm); }
# set $ds to format YYYY-MM-DD
:set ds ([:pick $ds 7 11] . $mm . [:pick $ds 4 6])

# create backup
/system backup save name="RB-$nama-backup";
/export compact file="RB-$nama-rsc";
:delay 3s;
:log info message="Configuration backup created";
# upload backup
/tool fetch address="$ftphost" user="$ftpuser" password="$ftppassword" mode=ftp port="$ftpport" src-path="RB-$nama-backup.backup" dst-path="$ftppath/RB-$nama-$ds-$waktu.backup" upload=yes;
/tool fetch address="$ftphost" user="$ftpuser" password="$ftppassword" mode=ftp port="$ftpport" src-path="RB-$nama-rsc.rsc" dst-path="$ftppath/RB-$nama-$ds-$waktu.rsc" upload=yes;
:delay 10s;
:log info message="Upload configuration success!";
# EOF

Bila ada pertanyaan seputar script diatas silahkan ditanyakan dikolom komentar. Semoga bermanfaat.

Baca juga :  Mikrotik Port Forward dengan Multiple Gateway

Leave a Comment