Cara Membuat Schedule Mikrotik Untuk Internet Kantor

Akan saya jelaskan Cara Membuat Schedule Mikrotik Untuk Internet Kantor pada hari dan jam tertentu. Jadi disini akan melakukan blok internet pada office hours atau jam kantor saja.

Perangkat yang digunakan

  1. Mikrotik CCR1009-7G-1C-1S+
  2. Versi 6.47.8 (stable)

Pembagian Jam Kantor

  1. Hari kerja yaitu Senin, Selasa, Rabu, Kamis, dan Jumat
  2. Hari Sabtu dan Minggu libur kantor (artinya internet open 2 hari penuh)
  3. Jam kerja kantor 08:30 s/d 17:00 WIB
  4. Jam istirahat 12:00 s/d 13:00 WIB

Pastinya di mikrotik Anda mempunyai script NAT untuk ke Internet yang dapat dimanfaatkan untuk dilakukan disable maupun enable sebagai patokan akses internet

Misalnya

chain=srcnat action=masquerade src-address=192.168.10.0/24 out-interface=eth2-FIRSTMEDIA comment="#TIME"

Ini merupakan contoh NAT ke internet, tanpa ini user tidak bisa akses ke internet.

Membuat Planning Waktu

Sebelum dilanjut, alahkan baiknya buat planning waktu kapan internet OFF dan kapan internet ON.

Untuk hari Senin, Selasa, Rabu, Kamis, dan Jumat

  1. 08:30 – 11:59 = Internet OFF
  2. 12:00 – 12:59 = Internet ON (jam istirahat)
  3. 13:00 – 16:59 = Internet OFF
  4. 17:00 – 08:29 = Internet ON (jam pulang kantor)

Untuk hari Sabtu dan Minggu Internet ON, karena hanya sebagian orang saja yg masuk, sehingga tidak mengganggu traffic.

Baca juga : Setting Router Mikrotik dengan ISP MyRepublic

Cara Membuat Schedule Mikrotik Untuk Internet Kantor

1. Buat schedule internet OFF pagi

Cara Membuat Schedule Mikrotik Untuk Internet Kantor
Cara Membuat Schedule Mikrotik Untuk Internet Kantor

Perhatikan script bagian bawah

:if (($result = "sat") || ($result = "sun")) do={
/ip firewall nat set [find comment~"#TIME"] disabled=no
} else={
/ip firewall nat set [find comment~"#TIME"] disabled=yes
}

Sebelumnya dilakukan pengecekan hari saat ini, jika Sabtu atau Minggu maka internet ON dan bila hari kerja Internet OFF pada jam 08:30 WIB

Baca juga :  Cara Backup Mikrotik ke FTP Server

Script lengkapnya disini

2. Buat Schedule internet ON siang (jam istirahat)

Cara Membuat Schedule Mikrotik Untuk Internet Kantor

Kenapa tidak ada script pengecekan hari ?
Karena untuk internet ON tidak memerlukan cek lagi, fokus pada internet OFF untuk melakukan pengecekan hari

/ip firewall nat set [find comment~"#TIME"] disabled=no

3. Buat schedule Internet OFF siang (setelah jam istirahat)

masih sama seperti sebelumnya, dilakukan pengecekan selain hari Sabtu dan Minggu internet OFF

:if (($result = "sat") || ($result = "sun")) do={
/ip firewall nat set [find comment~"#TIME"] disabled=no
} else={
/ip firewall nat set [find comment~"#TIME"] disabled=yes
}

4. Buat schedule Internet ON sore (setelah jam kantor)

Untuk internet ON tanpa perlu ada pengecekan hari

/ip firewall nat set [find comment~"#TIME"] disabled=no

Cukup sampai disini tutorial Cara Membuat Schedule Mikrotik Untuk Internet Kantor, bila ada pertanyaan atau koreksi kesalahan dari saya silahkan tinggalkan komentar dibawah

Script lengkapnya disini

Leave a Comment