Mikrotik Port Forward dengan Multiple Gateway

Mikrotik Port Forward dengan Multiple Gateway – Port Forward yang akan dibahas adalah port forward web server. Jadi saat user request web menggunakan ISP A dan web server akan mengembalikan juga menggunakan ISP A. Begitu juga jika user melakukan request menggunakan ISP B, web server akan mengembalikan dengan jalur ISP B.

Apakah ini failover?
Bisa Tidak dan bisa Iya, link aktif dari kedua-duanya. Jadi dalam waktu bersamaan user dapat melalui kedua ISP tersebut.
Akan jadi failover bila salah satu dari ISP ada yang DOWN

Topologi Mikrotik Port Forward dengan Multiple Gateway

Untuk lebih jelasnya silahkan perhatikan gambar topologi, agar lebih mudah memahami.

Mikrotik Port Forward dengan Multiple Gateway

Persiapan data yang diperlukan

  1. ISP Telkom
  2. ISP Icon
  3. Mikrotik
  4. Server

Data IP Address, disesuaikan dengan kebutuhan masing-masing

  1. ISP Telkom
    IP address : 192.168.249.114/30
    Gateway : 192.168.249.113
  2. ISP Icon
    IP address : 170.59.9.186/30
    Gateway : 170.59.9.185
  3. Mikrotik
    IP LAN : 10.203.1.203/24
  4. Server Web
    IP address : 192.168.20.04

Catatan: Server web sudah bisa diping dari mikrotik dan Server web juga bisa ping ke mikrotik LAN 10.203.1.203, saya tidak akan menerangkan VLAN pada cisco

Setting IP Address Mikrotik

Default koneksi adalah menggunakan ISP Telkom

Setting ISP Telkom

/ip address add address=192.168.249.114/30 comment="IP WAN TELKOM" interface=eth1-WAN-TELK network=192.168.249.112

Setting ISP Icon

/ip address add address=170.59.9.186/30 comment="to ICON+ (TRI)" interface=eth3-WAN-ICON network=170.59.9.184

Setting LAN

/ip address add address=10.203.1.203/24 comment="to LAN" interface=eth2-LAN network=10.203.1.0

Langkah selanjutnya dalam pembahasan Mikrotik Port Forward dengan Multiple Gateway

Baca juga :  Rsyslog Server untuk Log Router Mikrotik

Setting Routing Mikrotik

Routing ISP Telkom

/ip route add comment=TELKOM distance=2 gateway=192.168.249.113

Ini merupakan default routing yaitu pada ISP Telkom

Routing ISP Icon

/ip route add check-gateway=ping comment=ICON distance=1 gateway=170.59.9.185 routing-mark=to_ICON

Untuk secondary gateway diberi routing-mark to_ICON, agar kedua gateway bisa tetap aktif. Seperti gambar dibawah ini

Baca juga : 4 Langkah Membuat Router Mikrotik dengan Mudah

Default NAT

Buat default NAT ke ISP Telkom dan ISP Icon

/ip firewall nat add action=masquerade chain=srcnat comment="default configuration" out-interface=eth1-WAN-TELK to-addresses=0.0.0.0

add action=masquerade chain=srcnat out-interface=eth3-WAN-ICON to-addresses=0.0.0.0

Port Forward Web Server

Melakukan port forward dari lan ke Server

/ip firewall nat 
add action=dst-nat chain=dstnat comment="10.203.1.203 --> 192.168.20.104 (PGW)" dst-address=10.203.1.203 dst-port=80 protocol=tcp to-addresses=192.168.20.104 to-ports=80

add action=masquerade chain=srcnat dst-address=192.168.20.104

Membuat Mangle

Tanpa mangle sebenarnya masih bisa berjalan sesuai topologi, tapi hanya melalui ISP Telkom karena default routing ke ISP Telkom.
Sedangkan user yang akses melalui ISP Icon tidak akan mendapat balikan dari server, karena balikan data masih melalui default routing yaitu ISP Telkom.

Inti dari setting Mikrotik Port Forward dengan Multiple Gateway ada disini, kita akan membuat mangle khusus untuk ISP Icon agar input dan output bisa melewati ISP Icon.

Buat mark connection yang melewati ISP Icon

/ip firewall mangle
add action=mark-connection chain=prerouting comment=ICON connection-mark=no-mark in-interface=eth3-WAN-ICON new-connection-mark=ICON_conn passthrough=yes

add action=mark-routing chain=output comment=ICON connection-mark=ICON_conn new-routing-mark=to_ICON passthrough=no

Semua mark connection dari ISP Icon, outputnya akan di routing ke ISP Icon juga.
Sehingga tidak akan tertukar koneksi dengan ISP Telkom.

Hasil Log

Sampai disini Mikrotik Port Forward dengan Multiple Gateway sudah dapat berjalan dengan normal.

Script lengkapnya silahkan klik disini

Bila ada pertanyaan seputar pembahasan Mikrotik Port Forward dengan Multiple Gateway silahkan tulis dicomment

Baca juga :  Cara Backup Mikrotik ke FTP Server

Referensi : Google

Leave a Comment